Rapid7 Vulnerability & Exploit Database

RHSA-2009:0336: glib2 security update

Back to Search

RHSA-2009:0336: glib2 security update

Severity
5
CVSS
(AV:L/AC:L/Au:N/C:P/I:P/A:P)
Published
03/14/2009
Created
07/25/2018
Added
09/12/2009
Modified
07/04/2017

Description

GLib is the low-level core library that forms the basis for projects suchas GTK+ and GNOME. It provides data structure handling for C, portabilitywrappers, and interfaces for such runtime functionality as an event loop,threads, dynamic loading, and an object system.Diego Pettenò discovered multiple integer overflows causing heap-basedbuffer overflows in GLib's Base64 encoding and decoding functions. Anattacker could use these flaws to crash an application using GLib's Base64functions to encode or decode large, untrusted inputs, or, possibly,execute arbitrary code as the user running the application. (CVE-2008-4316)Note: No application shipped with Red Hat Enterprise Linux 5 uses theaffected functions. Third-party applications may, however, be affected.All users of glib2 should upgrade to these updated packages, which containbackported patches to resolve these issues.

Solution(s)

  • redhat-upgrade-glib2
  • redhat-upgrade-glib2-devel

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;