Rapid7 Vulnerability & Exploit Database

RHSA-2011:0885: firefox security and bug fix update

Back to Search

RHSA-2011:0885: firefox security and bug fix update

Severity
10
CVSS
(AV:N/AC:L/Au:N/C:C/I:C/A:C)
Published
06/30/2011
Created
07/25/2018
Added
07/05/2011
Modified
07/04/2017

Description

Mozilla Firefox is an open source web browser. XULRunner provides the XULRuntime environment for Mozilla Firefox.A flaw was found in the way Firefox handled malformed JPEG images. Awebsite containing a malicious JPEG image could cause Firefox to crash or,potentially, execute arbitrary code with the privileges of the user runningFirefox. (CVE-2011-2377)Multiple dangling pointer flaws were found in Firefox. A web pagecontaining malicious content could cause Firefox to crash or, potentially,execute arbitrary code with the privileges of the user running Firefox.(CVE-2011-0083, CVE-2011-0085, CVE-2011-2363)Several flaws were found in the processing of malformed web content. A webpage containing malicious content could cause Firefox to crash or,potentially, execute arbitrary code with the privileges of the user runningFirefox. (CVE-2011-2364, CVE-2011-2365, CVE-2011-2374, CVE-2011-2375,CVE-2011-2376)An integer overflow flaw was found in the way Firefox handled JavaScriptArray objects. A website containing malicious JavaScript could causeFirefox to execute that JavaScript with the privileges of the user runningFirefox. (CVE-2011-2371)A use-after-free flaw was found in the way Firefox handled malformedJavaScript. A website containing malicious JavaScript could cause Firefoxto execute that JavaScript with the privileges of the user running Firefox.(CVE-2011-2373)It was found that Firefox could treat two separate cookies asinterchangeable if both were for the same domain name but one of thosedomain names had a trailing "." character. This violates the same-originpolicy and could possibly lead to data being leaked to the wrong domain.(CVE-2011-2362)For technical details regarding these flaws, refer to the Mozilla securityadvisories for Firefox 3.6.18. You can find a link to the Mozillaadvisories in the References section of this erratum.This update also fixes the following bug:All Firefox users should upgrade to these updated packages, which containFirefox version 3.6.18, which corrects these issues. After installing theupdate, Firefox must be restarted for the changes to take effect.

Solution(s)

  • redhat-upgrade-firefox
  • redhat-upgrade-firefox-debuginfo
  • redhat-upgrade-xulrunner
  • redhat-upgrade-xulrunner-debuginfo
  • redhat-upgrade-xulrunner-devel

References

  • redhat-upgrade-firefox
  • redhat-upgrade-firefox-debuginfo
  • redhat-upgrade-xulrunner
  • redhat-upgrade-xulrunner-debuginfo
  • redhat-upgrade-xulrunner-devel

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;