Rapid7 VulnDB

Oracle Solaris 11: CVE-2015-0292: Vulnerability in OpenSSL

Back to Search

Oracle Solaris 11: CVE-2015-0292: Vulnerability in OpenSSL

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
03/19/2015
Created
07/25/2018
Added
05/29/2017
Modified
05/29/2017

Description

Integer underflow in the EVP_DecodeUpdate function in crypto/evp/encode.c in the base64-decoding implementation in OpenSSL before 0.9.8za, 1.0.0 before 1.0.0m, and 1.0.1 before 1.0.1h allows remote attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact via crafted base64 data that triggers a buffer overflow.

Solution(s)

  • oracle-solaris-11-2-upgrade-library-security-openssl-1-0-1-13-0-175-2-9-0-4-0
  • oracle-solaris-11-2-upgrade-library-security-openssl-openssl-fips-140-2-0-6-0-175-2-9-0-4-0

References

  • oracle-solaris-11-2-upgrade-library-security-openssl-1-0-1-13-0-175-2-9-0-4-0
  • oracle-solaris-11-2-upgrade-library-security-openssl-openssl-fips-140-2-0-6-0-175-2-9-0-4-0

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;