Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2009-1885

Back to Search

SUSE Linux Security Vulnerability: CVE-2009-1885

Severity
4
CVSS
(AV:N/AC:M/Au:N/C:N/I:N/A:P)
Published
08/11/2009
Created
07/25/2018
Added
02/17/2015
Modified
07/04/2017

Description

Stack consumption vulnerability in validators/DTD/DTDScanner.cpp in Apache Xerces C++ 2.7.0 and 2.8.0 allows context-dependent attackers to cause a denial of service (application crash) via vectors involving nested parentheses and invalid byte values in "simply nested DTD structures," as demonstrated by the Codenomicon XML fuzzing framework.

Solution(s)

  • suse-upgrade-libxerces-c-27
  • suse-upgrade-libxerces-c-28
  • suse-upgrade-libxerces-c-devel
  • suse-upgrade-libxerces-c28
  • suse-upgrade-xerces-c
  • suse-upgrade-xerces-c-devel

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;