Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2009-2632

Back to Search

SUSE Linux Security Vulnerability: CVE-2009-2632

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
09/08/2009
Created
07/25/2018
Added
02/17/2015
Modified
07/04/2017

Description

Buffer overflow in the SIEVE script component (sieve/script.c), as used in cyrus-imapd in Cyrus IMAP Server 2.2.13 and 2.3.14, and Dovecot 1.0 before 1.0.4 and 1.1 before 1.1.7, allows local users to execute arbitrary code and read or modify arbitrary messages via a crafted SIEVE script, related to the incorrect use of the sizeof operator for determining buffer length, combined with an integer signedness error.

Solution(s)

  • suse-upgrade-cyrus-imapd
  • suse-upgrade-cyrus-imapd-devel
  • suse-upgrade-dovecot
  • suse-upgrade-dovecot-devel
  • suse-upgrade-dovecot11
  • suse-upgrade-dovecot11-backend-mysql
  • suse-upgrade-dovecot11-backend-pgsql
  • suse-upgrade-dovecot11-backend-sqlite
  • suse-upgrade-dovecot11-devel
  • suse-upgrade-dovecot11-fts-lucene
  • suse-upgrade-perl-cyrus-imap
  • suse-upgrade-perl-cyrus-sieve-managesieve

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;