Rapid7 Vulnerability & Exploit Database

USN-2431-1: mod_wsgi vulnerability

Back to Search

USN-2431-1: mod_wsgi vulnerability

Severity
7
CVSS
(AV:L/AC:M/Au:N/C:C/I:C/A:C)
Published
12/03/2014
Created
07/25/2018
Added
12/04/2014
Modified
07/09/2020

Description

mod_wsgi before 4.2.4 for Apache, when creating a daemon process group, does not properly handle when group privileges cannot be dropped, which might allow attackers to gain privileges via unspecified vectors.

Solution(s)

  • ubuntu-upgrade-libapache2-mod-wsgi
  • ubuntu-upgrade-libapache2-mod-wsgi-py3

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;