Rapid7 Vulnerability & Exploit Database

Alma Linux: CVE-2019-10130: Important: postgresql:9.6 security update (ALSA-2020-5619)

Back to Search

Alma Linux: CVE-2019-10130: Important: postgresql:9.6 security update (ALSA-2020-5619)

Severity
4
CVSS
(AV:N/AC:L/Au:S/C:P/I:N/A:N)
Published
07/30/2019
Created
05/05/2022
Added
05/04/2022
Modified
05/04/2022

Description

A vulnerability was found in PostgreSQL versions 11.x up to excluding 11.3, 10.x up to excluding 10.8, 9.6.x up to, excluding 9.6.13, 9.5.x up to, excluding 9.5.17. PostgreSQL maintains column statistics for tables. Certain statistics, such as histograms and lists of most common values, contain values taken from the column. PostgreSQL does not evaluate row security policies before consulting those statistics during query planning; an attacker can exploit this to read the most common values of certain columns. Affected columns are those for which the attacker has SELECT privilege and for which, in an ordinary query, row-level security prunes the set of rows visible to the attacker.

Solution(s)

  • alma-upgrade-postgresql
  • alma-upgrade-postgresql-contrib
  • alma-upgrade-postgresql-docs
  • alma-upgrade-postgresql-plperl
  • alma-upgrade-postgresql-plpython3
  • alma-upgrade-postgresql-pltcl
  • alma-upgrade-postgresql-server
  • alma-upgrade-postgresql-server-devel
  • alma-upgrade-postgresql-static
  • alma-upgrade-postgresql-test
  • alma-upgrade-postgresql-test-rpm-macros

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;