Rapid7 Vulnerability & Exploit Database

Alma Linux: CVE-2019-12795: Low: GNOME security, bug fix, and enhancement update (ALSA-2019-3553)

Back to Search

Alma Linux: CVE-2019-12795: Low: GNOME security, bug fix, and enhancement update (ALSA-2019-3553)

Severity
5
CVSS
(AV:L/AC:L/Au:N/C:P/I:P/A:P)
Published
06/11/2019
Created
05/05/2022
Added
05/04/2022
Modified
05/13/2022

Description

daemon/gvfsdaemon.c in gvfsd from GNOME gvfs before 1.38.3, 1.40.x before 1.40.2, and 1.41.x before 1.41.3 opened a private D-Bus server socket without configuring an authorization rule. A local attacker could connect to this server socket and issue D-Bus method calls. (Note that the server socket only accepts a single connection, so the attacker would have to discover the server and connect to the socket before its owner does.)

Solution(s)

  • alma-upgrade-gdk-pixbuf2
  • alma-upgrade-gdk-pixbuf2-devel
  • alma-upgrade-gdk-pixbuf2-modules
  • alma-upgrade-gdk-pixbuf2-xlib
  • alma-upgrade-gdk-pixbuf2-xlib-devel
  • alma-upgrade-gnome-desktop3
  • alma-upgrade-gnome-desktop3-devel
  • alma-upgrade-libpurple
  • alma-upgrade-libpurple-devel
  • alma-upgrade-pidgin
  • alma-upgrade-pidgin-devel

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;