Rapid7 Vulnerability & Exploit Database

Alma Linux: CVE-2019-3842: Moderate: systemd security, bug fix, and enhancement update (ALSA-2021-1611)

Back to Search

Alma Linux: CVE-2019-3842: Moderate: systemd security, bug fix, and enhancement update (ALSA-2021-1611)

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
04/09/2019
Created
05/05/2022
Added
05/04/2022
Modified
05/04/2022

Description

In systemd before v242-rc4, it was discovered that pam_systemd does not properly sanitize the environment before using the XDG_SEAT variable. It is possible for an attacker, in some particular configurations, to set a XDG_SEAT environment variable which allows for commands to be checked against polkit policies using the "allow_active" element rather than "allow_any".

Solution(s)

  • alma-upgrade-systemd
  • alma-upgrade-systemd-container
  • alma-upgrade-systemd-devel
  • alma-upgrade-systemd-journal-remote
  • alma-upgrade-systemd-libs
  • alma-upgrade-systemd-pam
  • alma-upgrade-systemd-tests
  • alma-upgrade-systemd-udev

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;