Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2011-4940: Vulnerability in python < 2.6.7 may allow XSS

Back to Search

Alpine Linux: CVE-2011-4940: Vulnerability in python < 2.6.7 may allow XSS

Severity
3
CVSS
(AV:N/AC:H/Au:N/C:N/I:P/A:N)
Published
06/27/2012
Created
07/25/2018
Added
08/30/2017
Modified
09/22/2017

Description

The list_directory function in Lib/SimpleHTTPServer.py in SimpleHTTPServer in Python before 2.5.6c1, 2.6.x before 2.6.7 rc2, and 2.7.x before 2.7.2 does not place a charset parameter in the Content-Type HTTP header, which makes it easier for remote attackers to conduct cross-site scripting (XSS) attacks against Internet Explorer 7 via UTF-7 encoding.

Solution(s)

  • alpine-linux-upgrade-python

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;