Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2012-1184: Vulnerability in asterisk < 1.8.11.1 may allow remote privilege escalation

Back to Search

Alpine Linux: CVE-2012-1184: Vulnerability in asterisk < 1.8.11.1 may allow remote privilege escalation

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
09/18/2012
Created
07/25/2018
Added
09/20/2017
Modified
11/03/2017

Description

Stack-based buffer overflow in the ast_parse_digest function in main/utils.c in Asterisk 1.8.x before 1.8.10.1 and 10.x before 10.2.1 allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a long string in an HTTP Digest Authentication header.

Solution(s)

  • alpine-linux-upgrade-asterisk

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;