Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2012-2393: Multiple vulnerabilities in wireshark < 1.6.8|1.4.13 maycode execution

Back to Search

Alpine Linux: CVE-2012-2393: Multiple vulnerabilities in wireshark < 1.6.8|1.4.13 maycode execution

Severity
3
CVSS
(AV:A/AC:L/Au:N/C:N/I:N/A:P)
Published
06/30/2012
Created
07/25/2018
Added
09/20/2017
Modified
09/22/2017

Description

epan/dissectors/packet-diameter.c in the DIAMETER dissector in Wireshark 1.4.x before 1.4.13 and 1.6.x before 1.6.8 does not properly construct certain array data structures, which allows remote attackers to cause a denial of service (application crash) via a crafted packet that triggers incorrect memory allocation.

Solution(s)

  • alpine-linux-upgrade-wireshark

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;