Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2012-3482: Vulnerability in fetchmail < 6.3.22 allow remote denial of service

Back to Search

Alpine Linux: CVE-2012-3482: Vulnerability in fetchmail < 6.3.22 allow remote denial of service

Severity
6
CVSS
(AV:N/AC:M/Au:N/C:P/I:N/A:P)
Published
12/21/2012
Created
07/25/2018
Added
08/30/2017
Modified
09/22/2017

Description

Fetchmail 5.0.8 through 6.3.21, when using NTLM authentication in debug mode, allows remote NTLM servers to (1) cause a denial of service (crash and delayed delivery of inbound mail) via a crafted NTLM response that triggers an out-of-bounds read in the base64 decoder, or (2) obtain sensitive information from memory via an NTLM Type 2 message with a crafted Target Name structure, which triggers an out-of-bounds read.

Solution(s)

  • alpine-linux-upgrade-fetchmail

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;