Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2013-2004: libX11 <= 1.5.99.901>

Back to Search

Alpine Linux: CVE-2013-2004: libX11 <= 1.5.99.901

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
06/15/2013
Created
07/25/2018
Added
08/30/2017
Modified
09/22/2017

Description

The (1) GetDatabase and (2) _XimParseStringFile functions in X.org libX11 1.5.99.901 (1.6 RC1) and earlier do not restrict the recursion depth when processing directives to include files, which allows X servers to cause a denial of service (stack consumption) via a crafted file.

Solution(s)

  • alpine-linux-upgrade-libx11

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;