Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2014-3483: ruby-rails vulnerabilities in PostgreSQL adapter for Active Record

Back to Search

Alpine Linux: CVE-2014-3483: ruby-rails vulnerabilities in PostgreSQL adapter for Active Record

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
07/07/2014
Created
07/25/2018
Added
08/30/2017
Modified
01/29/2019

Description

SQL injection vulnerability in activerecord/lib/active_record/connection_adapters/postgresql/quoting.rb in the PostgreSQL adapter for Active Record in Ruby on Rails 4.x before 4.0.7 and 4.1.x before 4.1.3 allows remote attackers to execute arbitrary SQL commands by leveraging improper range quoting.

Solution(s)

  • alpine-linux-upgrade-ruby-actionmailer
  • alpine-linux-upgrade-ruby-railties
  • alpine-linux-upgrade-ruby-redmine-actionmailer

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;