Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI 2: CVE-2023-26253: Security patch for glusterfs (ALAS-2023-2071)

Free InsightVM Trial No Credit Card Necessary
2024 Attack Intel Report Latest research by Rapid7 Labs
Back to Search

Amazon Linux AMI 2: CVE-2023-26253: Security patch for glusterfs (ALAS-2023-2071)

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
02/21/2023
Created
06/08/2023
Added
06/08/2023
Modified
06/08/2023

Description

In Gluster GlusterFS 11.0, there is an xlators/mount/fuse/src/fuse-bridge.c notify stack-based buffer over-read.

Solution(s)

  • amazon-linux-ami-2-upgrade-glusterfs
  • amazon-linux-ami-2-upgrade-glusterfs-api
  • amazon-linux-ami-2-upgrade-glusterfs-api-devel
  • amazon-linux-ami-2-upgrade-glusterfs-cli
  • amazon-linux-ami-2-upgrade-glusterfs-client-xlators
  • amazon-linux-ami-2-upgrade-glusterfs-debuginfo
  • amazon-linux-ami-2-upgrade-glusterfs-devel
  • amazon-linux-ami-2-upgrade-glusterfs-fuse
  • amazon-linux-ami-2-upgrade-glusterfs-libs
  • amazon-linux-ami-2-upgrade-glusterfs-rdma
  • amazon-linux-ami-2-upgrade-python2-gluster

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;