Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI: Security patch for yum (ALAS-2014-315) (CVE-2014-0022)

Back to Search

Amazon Linux AMI: Security patch for yum (ALAS-2014-315) (CVE-2014-0022)

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:P/A:N)
Published
01/26/2014
Created
07/25/2018
Added
04/08/2014
Modified
07/04/2017

Description

The installUpdates function in yum-cron/yum-cron.py in yum 3.4.3 and earlier does not properly check the return value of the sigCheckPkg function, which allows remote attackers to bypass the RMP package signing restriction via an unsigned package.

Solution(s)

  • amazon-linux-upgrade-yum
  • amazon-linux-upgrade-yum-cron
  • amazon-linux-upgrade-yum-cron-daily
  • amazon-linux-upgrade-yum-cron-hourly
  • amazon-linux-upgrade-yum-cron-security

References

  • amazon-linux-upgrade-yum
  • amazon-linux-upgrade-yum-cron
  • amazon-linux-upgrade-yum-cron-daily
  • amazon-linux-upgrade-yum-cron-hourly
  • amazon-linux-upgrade-yum-cron-security

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;