Rapid7 Vulnerability & Exploit Database

Apache HTTPD: mod_proxy_ajp information disclosure (CVE-2009-1191)

Back to Search

Apache HTTPD: mod_proxy_ajp information disclosure (CVE-2009-1191)

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:P/I:N/A:N)
Published
04/23/2009
Created
07/25/2018
Added
04/12/2012
Modified
05/27/2016

Description

The affected asset is vulnerable to this vulnerability ONLY if it is running one of the following modules: mod_proxy_ajp. Review your web server configuration for validation. An information disclosure flaw was found in mod_proxy_ajp in version 2.2.11 only. In certain situations, if a user sent a carefully crafted HTTP request, the server could return a response intended for another user.

Solution(s)

  • apache-httpd-upgrade-2_2_12

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;