Use-after-free vulnerability in the Zend engine in PHP before 5.2.15 and 5.3.x before 5.3.4 might allow context-dependent attackers to cause a denial of service (heap memory corruption) or have unspecified other impact via vectors related to use of __set, __get, __isset, and __unset methods on objects accessed by a reference.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| F5 Big Ip | — | Update F5 BIG-IP to the latest version | Jun 17, 2026 | Sep 20, 2013 |
| Gentoo Linux | — | Upgrade dev-lang/php. | Oct 30, 2017 | Jan 18, 2011 |
| Php | — | Upgrade to PHP version 5.3.4Upgrade to PHP version 5.2.15 | Oct 1, 2012 | Jan 18, 2011 |
| Suse | — | Upgrade php5-dbaseUpgrade php5-ldapUpgrade php5-tokenizerUpgrade php5-odbcUpgrade php5-gdUpgrade php5-sysvmsgUpgrade php5-pearUpgrade php5-suhosinUpgrade php5-zlibUpgrade php5-snmpUpgrade php5-soapUpgrade php5-sysvshmUpgrade php5-bz2Upgrade php5-dbaUpgrade php5-calendarUpgrade php5-shmopUpgrade php5-curlUpgrade php5-pspellUpgrade php5-pgsqlUpgrade php5-wddxUpgrade php5-domUpgrade php5-fastcgiUpgrade php5-exifUpgrade php5-sysvsemUpgrade php5-opensslUpgrade php5-iconvUpgrade php5-mbstringUpgrade php5-gmpUpgrade php5-zipUpgrade php5-mysqlUpgrade php5-xmlwriterUpgrade apache2-mod_php5Upgrade php5-bcmathUpgrade php5-hashUpgrade php5-jsonUpgrade php5Upgrade php5-ftpUpgrade php5-xslUpgrade php5-xmlreaderUpgrade php5-mcryptUpgrade php5-pcntlUpgrade php5-gettextUpgrade php5-ctypeUpgrade php5-pdoUpgrade php5-xmlrpc | Feb 17, 2015 | Jun 28, 2013 |
| Ubuntu | — | Upgrade php5-cgiUpgrade php5-intlUpgrade php5-gdUpgrade php5-cliUpgrade php5-curlUpgrade php5-commonUpgrade php-pearUpgrade php5-devUpgrade libapache2-mod-php5Upgrade php5 | Nov 8, 2024 | Jan 18, 2011 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub