Multiple stack-based buffer overflows in PostgreSQL before 8.4.20, 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3 allow remote authenticated users to cause a denial of service (crash) or possibly execute arbitrary code via vectors related to an incorrect MAXDATELEN constant and datetime values involving (1) intervals, (2) timestamps, or (3) timezones, a different vulnerability than CVE-2014-0065.
CVSS Details
- CVSS 3.1 Base Score: 8.8
Covered by Rapid7
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Alpine Linux | — | Upgrade postgresql | Sep 20, 2017 | Mar 31, 2014 |
| Centos_linux | — | Upgrade postgresql84-develUpgrade postgresql-develUpgrade postgresql84Upgrade postgresql-pltclUpgrade postgresql-plpythonUpgrade postgresql-plperlUpgrade postgresql84-contribUpgrade postgresql-contribUpgrade postgresql-docsUpgrade postgresql84-plpythonUpgrade postgresql84-testUpgrade postgresql84-tclUpgrade postgresql84-libsUpgrade postgresql84-serverUpgrade postgresql84-pltclUpgrade postgresql84-pythonUpgrade postgresql84-plperlUpgrade postgresqlUpgrade postgresql84-docsUpgrade postgresql-tclUpgrade postgresql-libsUpgrade postgresql-plUpgrade postgresql-serverUpgrade postgresql-pythonUpgrade postgresql-test | Dec 1, 2016 | Mar 31, 2014 |
| Freebsd | — | Upgrade postgresql-server | Dec 10, 2025 | Feb 20, 2014 |
| Gentoo Linux | — | Upgrade dev-db/postgresql-server. | Oct 30, 2017 | Mar 31, 2014 |
| Oracle_linux | — | Upgrade postgresql84-tclUpgrade postgresql84-serverUpgrade postgresql84-testUpgrade postgresql84-libsUpgrade postgresql-develUpgrade postgresql-docsUpgrade postgresql84-develUpgrade postgresql84-docsUpgrade postgresql-pltclUpgrade postgresql84Upgrade postgresql84-pltclUpgrade postgresql-contribUpgrade postgresql84-pythonUpgrade postgresql84-contribUpgrade postgresql-plpythonUpgrade postgresqlUpgrade postgresql84-plperlUpgrade postgresql84-plpythonUpgrade postgresql-plperlUpgrade postgresql-libsUpgrade postgresql-serverUpgrade postgresql-test | Oct 16, 2024 | Mar 28, 2014 |
| Postgres | — | Upgrade to PostgreSQL version 9.3.3 | Apr 1, 2014 | Mar 31, 2014 |
| Suse | — | Upgrade postgresql93Upgrade postgresql94-develUpgrade postgresql91Upgrade postgresql94-serverUpgrade postgresql93-develUpgrade postgresql10-contribUpgrade postgresql10-develUpgrade postgresql93-contribUpgrade postgresql10Upgrade postgresql93-serverUpgrade postgresql10-plperlUpgrade libpq5Upgrade postgresql91-serverUpgrade postgresql10-docsUpgrade postgresql96-docsUpgrade postgresql91-contribUpgrade libpq5-32bitUpgrade postgresql96-contribUpgrade postgresql91-docsUpgrade postgresql94Upgrade postgresql93-docsUpgrade postgresql10-plpythonUpgrade postgresql96Upgrade libecpg6Upgrade postgresql96-develUpgrade postgresql10-serverUpgrade postgresql94-contribUpgrade postgresql91-develUpgrade postgresql10-pltclUpgrade postgresql94-docsUpgrade postgresql96-server | Dec 18, 2015 | Mar 28, 2014 |
| Ubuntu | — | Upgrade postgresql-9.1Upgrade postgresql-8.4 | Nov 8, 2024 | Mar 31, 2014 |
Prioritize with Active Threat Intelligence
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub