The destroy_buffers function in libavcodec/sanm.c in FFmpeg before 2.7.2 does not properly maintain height and width values in the video context, which allows remote attackers to cause a denial of service (segmentation violation and application crash) or possibly have unspecified other impact via crafted LucasArts Smush video data.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Debian | — | Upgrade ffmpeg | Feb 20, 2019 | Sep 5, 2015 |
| Ffmpeg | — | Upgrade to FFmpeg version 2.8Upgrade to FFmpeg version 2.6.4Upgrade to FFmpeg version 2.5.8Upgrade to FFmpeg version 2.7.2Upgrade to FFmpeg version 2.4.11 | Sep 29, 2017 | Sep 6, 2015 |
| Freebsd | — | Upgrade avidemuxUpgrade ffmpeg2Upgrade avidemux2Upgrade ffmpeg25Upgrade ffmpeg-develUpgrade ffmpeg1Upgrade kodiUpgrade mencoderUpgrade ffmpeg-011Upgrade avidemux26Upgrade ffmpeg26Upgrade mplayerUpgrade plexhometheaterUpgrade ffmpeg0Upgrade ffmpegUpgrade ffmpeg23Upgrade ffmpeg24Upgrade mythtv-frontendUpgrade mythtvUpgrade libavUpgrade handbrakeUpgrade gstreamer1-libavUpgrade gstreamer-ffmpeg | Dec 10, 2025 | Sep 20, 2015 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub