Format string vulnerability in the php_snmp_error function in ext/snmp/snmp.c in PHP before 5.5.34, 5.6.x before 5.6.20, and 7.x before 7.0.5 allows remote attackers to execute arbitrary code via format string specifiers in an SNMP::get call.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Amazon_linux | — | Upgrade php56Upgrade php55 | May 3, 2016 | May 3, 2016 |
| Apple Osx Apachemodphp | — | Upgrade macOS to the latest version | Jun 2, 2016 | May 20, 2016 |
| Debian | — | Upgrade php7.0Upgrade php5 | Apr 28, 2016 | Apr 27, 2016 |
| Gentoo Linux | — | Upgrade dev-lang/php. | Oct 30, 2017 | May 20, 2016 |
| Hpsmh | — | Upgrade to the latest version of HP System Management Homepage | Oct 27, 2016 | May 20, 2016 |
| Huawei Euleros 2_0_sp2 | — | Upgrade phpUpgrade php-gdUpgrade php-pgsqlUpgrade php-soapUpgrade php-ldapUpgrade php-pdoUpgrade php-processUpgrade php-commonUpgrade php-xmlUpgrade php-mysqlUpgrade php-cliUpgrade php-recodeUpgrade php-xmlrpcUpgrade php-odbc | Nov 3, 2020 | May 20, 2016 |
| Huawei Euleros 2_0_sp3 | — | Upgrade php-soapUpgrade php-mysqlUpgrade php-processUpgrade php-gdUpgrade php-xmlrpcUpgrade phpUpgrade php-pgsqlUpgrade php-odbcUpgrade php-xmlUpgrade php-cliUpgrade php-ldapUpgrade php-commonUpgrade php-recodeUpgrade php-pdo | Sep 28, 2020 | May 20, 2016 |
| Php | — | Upgrade to PHP version 7.0.5Upgrade to PHP version 5.5.34Upgrade to PHP version 5.6.20 | Jun 3, 2016 | May 20, 2016 |
| Redhat_linux | — | No solution exists | Jul 9, 2025 | Mar 2, 2016 |
| Suse | — | Upgrade php5-calendarUpgrade php5-xmlwriterUpgrade php5-mysqlUpgrade php5-zlibUpgrade php5-wddxUpgrade php5-gmpUpgrade apache2-mod_php5Upgrade php5-mbstringUpgrade php5-posixUpgrade php5-enchantUpgrade php5-bz2Upgrade php5-pcntlUpgrade php5-odbcUpgrade php5-fpmUpgrade php5-opcacheUpgrade php5-pgsqlUpgrade php5-curlUpgrade php5-tokenizerUpgrade php5-develUpgrade php5-soapUpgrade php5-dbaUpgrade php5-sqliteUpgrade php5-exifUpgrade php5-shmopUpgrade php5-gettextUpgrade php5-pdoUpgrade php5-xmlreaderUpgrade php5-pharUpgrade php5-sysvsemUpgrade php5-opensslUpgrade php5-socketsUpgrade php5-bcmathUpgrade php5-ldapUpgrade php5-xmlrpcUpgrade php5-xslUpgrade php5-pearUpgrade php5-sysvmsgUpgrade php5-ctypeUpgrade php5-zipUpgrade php5-fileinfoUpgrade php5-pspellUpgrade php5-snmpUpgrade php5-intlUpgrade php5-gdUpgrade php5-fastcgiUpgrade php5-iconvUpgrade php5-jsonUpgrade php5-sysvshmUpgrade php5Upgrade php5-suhosinUpgrade php5-domUpgrade php5-ftpUpgrade php5-mcrypt | May 11, 2016 | May 11, 2016 |
| Ubuntu | — | Upgrade libapache2-mod-php5Upgrade php7.0-cgiUpgrade php5-fpmUpgrade php7.0-cliUpgrade libapache2-mod-php7.0Upgrade php7.0-fpmUpgrade php5-cliUpgrade php5-cgi | May 24, 2016 | May 20, 2016 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub