Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2011-1579: MediaWiki: Multiple vulnerabilities

Back to Search

Gentoo Linux: CVE-2011-1579: MediaWiki: Multiple vulnerabilities

Severity
6
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:N)
Published
04/26/2011
Created
07/25/2018
Added
10/30/2017
Modified
10/30/2017

Description

The checkCss function in includes/Sanitizer.php in the wikitext parser in MediaWiki before 1.16.3 does not properly validate Cascading Style Sheets (CSS) token sequences, which allows remote attackers to conduct cross-site scripting (XSS) attacks or obtain sensitive information by using the \2f\2a and \2a\2f hex strings to surround CSS comments.

Solution(s)

  • gentoo-linux-upgrade-www-apps-mediawiki

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;