Rapid7 Vulnerability & Exploit Database

ELSA-2013-1274 Important: Oracle Linux hplip security update

Back to Search

ELSA-2013-1274 Important: Oracle Linux hplip security update

Severity
7
CVSS
(AV:L/AC:M/Au:N/C:C/I:C/A:C)
Published
09/23/2013
Created
07/25/2018
Added
09/25/2013
Modified
07/04/2017

Description

The check_permission_v1 function in base/pkit.py in HP Linux Imaging and Printing (HPLIP) through 3.13.9 does not properly use D-Bus for communication with a polkit authority, which allows local users to bypass intended access restrictions by leveraging a PolkitUnixProcess PolkitSubject race condition via a (1) setuid process or (2) pkexec process.

Solution(s)

  • oracle-linux-upgrade-hpijs
  • oracle-linux-upgrade-hplip
  • oracle-linux-upgrade-hplip-common
  • oracle-linux-upgrade-hplip-gui
  • oracle-linux-upgrade-hplip-libs
  • oracle-linux-upgrade-libsane-hpaio

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;