Rapid7 Vulnerability & Exploit Database

RHSA-2002:070: Updated mod_python packages available

Back to Search

RHSA-2002:070: Updated mod_python packages available

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
05/16/2002
Created
07/25/2018
Added
10/28/2005
Modified
07/04/2017

Description

Updated mod_python packages have been made available for Red Hat Linux 7.2 and 7.3. These updates close a security issue in mod_python which allows the publisher handler to use modules which have only been indirectly imported. This re-issue adds packages for Red Hat Linux 7.3.

mod_python is a module that embeds the Python language interpreter within the Apache Web server. mod_python versions 2.7.6 and earlier allow a module which is indirectly imported by a published module to then be accessed by the publisher handler. This could allow a remote attacker to abuse imported modules leading to file modifications or more serious breaches. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CAN-2002-0185 to this issue.

Solution(s)

  • redhat-upgrade-mod_python

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;