Vulnerability & Exploit Database

Back to search

RHSA-2014:0316: thunderbird security update

Severity CVSS Published Added Modified
9 (AV:N/AC:M/Au:N/C:C/I:C/A:C) March 19, 2014 March 27, 2014 July 04, 2017

Available Exploits 

Description

Mozilla Thunderbird is a standalone mail and newsgroup client.Several flaws were found in the processing of malformed web content. A webpage containing malicious content could cause Thunderbird to crash or,potentially, execute arbitrary code with the privileges of the user runningThunderbird. (CVE-2014-1493, CVE-2014-1510, CVE-2014-1511, CVE-2014-1512,CVE-2014-1513, CVE-2014-1514)Several information disclosure flaws were found in the way Thunderbirdprocessed malformed web content. An attacker could use these flaws to gainaccess to sensitive information such as cross-domain content or protectedmemory addresses or, potentially, cause Thunderbird to crash.(CVE-2014-1497, CVE-2014-1508, CVE-2014-1505)A memory corruption flaw was found in the way Thunderbird rendered certainPDF files. An attacker able to trick a user into installing a maliciousextension could use this flaw to crash Thunderbird or, potentially, executearbitrary code with the privileges of the user running Thunderbird.(CVE-2014-1509)Red Hat would like to thank the Mozilla project for reporting these issues.Upstream acknowledges Benoit Jacob, Olli Pettay, Jan Varga, Jan de Mooij,Jesse Ruderman, Dan Gohman, Christoph Diehl, Atte Kettunen, Tyson Smith,Jesse Schwartzentruber, John Thomson, Robert O'Callahan, Mariusz Mlynski,Jüri Aedla, George Hotz, and the security research firm VUPEN as theoriginal reporters of these issues.Note: All of the above issues cannot be exploited by a specially-craftedHTML mail message as JavaScript is disabled by default for mail messages.They could be exploited another way in Thunderbird, for example, whenviewing the full remote content of an RSS feed.For technical details regarding these flaws, refer to the Mozilla securityadvisories for Thunderbird 24.4.0. You can find a link to the Mozillaadvisories in the References section of this erratum.All Thunderbird users should upgrade to this updated package, whichcontains Thunderbird version 24.4.0, which corrects these issues.After installing the update, Thunderbird must be restarted for the changesto take effect.

Scan For This Vulnerability

Use our top-rated tool to discover, prioritize, and remediate your vulnerabilities

 Free InsightVM Trial

References

Solution

redhat-upgrade-thunderbird

Related Vulnerabilities