Rapid7 Vulnerability & Exploit Database

Oracle Solaris 11: CVE-2018-17294: Vulnerability in Liblouis

Back to Search

Oracle Solaris 11: CVE-2018-17294: Vulnerability in Liblouis

Severity
4
CVSS
(AV:N/AC:M/Au:N/C:N/I:N/A:P)
Published
09/21/2018
Created
11/21/2019
Added
11/20/2019
Modified
08/27/2021

Description

The matchCurrentInput function inside lou_translateString.c of Liblouis prior to 3.7 does not check the input string's length, allowing attackers to cause a denial of service (application crash via out-of-bounds read) by crafting an input file with certain translation dictionaries.

Solution(s)

  • oracle-solaris-11-4-upgrade-value-desktop-pdf-viewer-evince-3-25-4-11-4-15-0-1-2-0
  • oracle-solaris-11-4-upgrade-value-desktop-xdg-xdg-utils-1-1-3-11-4-15-0-1-2-0
  • oracle-solaris-11-4-upgrade-value-image-library-librsvg-2-40-16-11-4-15-0-1-2-0
  • oracle-solaris-11-4-upgrade-value-library-liblouis-3-5-0-11-4-15-0-1-2-0
  • oracle-solaris-11-4-upgrade-value-library-libsoup-2-57-1-11-4-15-0-1-2-0

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;