Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2004-0835

Back to Search

SUSE Linux Security Vulnerability: CVE-2004-0835

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
11/03/2004
Created
07/25/2018
Added
02/17/2015
Modified
07/04/2017

Description

MySQL 3.x before 3.23.59, 4.x before 4.0.19, 4.1.x before 4.1.2, and 5.x before 5.0.1, checks the CREATE/INSERT rights of the original table instead of the target table in an ALTER TABLE RENAME operation, which could allow attackers to conduct unauthorized activities.

Solution(s)

  • suse-upgrade-mysql
  • suse-upgrade-mysql-max

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;