Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2008-3657

Back to Search

SUSE Linux Security Vulnerability: CVE-2008-3657

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
08/12/2008
Created
07/25/2018
Added
02/17/2015
Modified
07/04/2017

Description

The dl module in Ruby 1.8.5 and earlier, 1.8.6 through 1.8.6-p286, 1.8.7 through 1.8.7-p71, and 1.9 through r18423 does not check "taintness" of inputs, which allows context-dependent attackers to bypass safe levels and execute dangerous functions by accessing a library using DL.dlopen.

Solution(s)

  • suse-upgrade-ruby
  • suse-upgrade-ruby-devel
  • suse-upgrade-ruby-doc-html
  • suse-upgrade-ruby-doc-ri
  • suse-upgrade-ruby-examples
  • suse-upgrade-ruby-test-suite
  • suse-upgrade-ruby-tk

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;