Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2008-3834

Back to Search

SUSE Linux Security Vulnerability: CVE-2008-3834

Severity
2
CVSS
(AV:L/AC:L/Au:N/C:N/I:N/A:P)
Published
10/07/2008
Created
07/25/2018
Added
02/17/2015
Modified
07/04/2017

Description

The dbus_signature_validate function in the D-bus library (libdbus) before 1.2.4 allows remote attackers to cause a denial of service (application abort) via a message containing a malformed signature, which triggers a failed assertion error.

Solution(s)

  • suse-upgrade-dbus-1
  • suse-upgrade-dbus-1-32bit
  • suse-upgrade-dbus-1-64bit
  • suse-upgrade-dbus-1-debuginfo
  • suse-upgrade-dbus-1-debuginfo-32bit
  • suse-upgrade-dbus-1-debuginfo-x86
  • suse-upgrade-dbus-1-debugsource
  • suse-upgrade-dbus-1-devel
  • suse-upgrade-dbus-1-devel-32bit
  • suse-upgrade-dbus-1-devel-doc
  • suse-upgrade-dbus-1-glib
  • suse-upgrade-dbus-1-glib-32bit
  • suse-upgrade-dbus-1-glib-64bit
  • suse-upgrade-dbus-1-glib-x86
  • suse-upgrade-dbus-1-gtk
  • suse-upgrade-dbus-1-java
  • suse-upgrade-dbus-1-mono
  • suse-upgrade-dbus-1-python
  • suse-upgrade-dbus-1-qt
  • suse-upgrade-dbus-1-qt3
  • suse-upgrade-dbus-1-qt3-32bit
  • suse-upgrade-dbus-1-qt3-64bit
  • suse-upgrade-dbus-1-qt3-devel
  • suse-upgrade-dbus-1-qt3-x86
  • suse-upgrade-dbus-1-x11
  • suse-upgrade-dbus-1-x11-debuginfo
  • suse-upgrade-dbus-1-x11-debugsource
  • suse-upgrade-dbus-1-x86
  • suse-upgrade-libdbus-1-3
  • suse-upgrade-libdbus-1-3-32bit
  • suse-upgrade-sap-aio-release
  • suse-upgrade-suse-release

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;