Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2008-4456

Back to Search

SUSE Linux Security Vulnerability: CVE-2008-4456

Severity
3
CVSS
(AV:N/AC:H/Au:N/C:N/I:P/A:N)
Published
10/06/2008
Created
07/25/2018
Added
02/17/2015
Modified
07/04/2017

Description

Cross-site scripting (XSS) vulnerability in the command-line client in MySQL 5.0.26 through 5.0.45, and other versions including versions later than 5.0.45, when the --html option is enabled, allows attackers to inject arbitrary web script or HTML by placing it in a database cell, which might be accessed by this client when composing an HTML document. NOTE: as of 20081031, the issue has not been fixed in MySQL 5.0.67.

Solution(s)

  • suse-upgrade-libmysqlclient-devel
  • suse-upgrade-libmysqlclient15
  • suse-upgrade-libmysqlclient15-32bit
  • suse-upgrade-libmysqlclient15-64bit
  • suse-upgrade-libmysqlclient_r15
  • suse-upgrade-libmysqlclient_r15-32bit
  • suse-upgrade-libmysqlclient_r15-64bit
  • suse-upgrade-mysql
  • suse-upgrade-mysql-bench
  • suse-upgrade-mysql-client
  • suse-upgrade-mysql-debug
  • suse-upgrade-mysql-devel
  • suse-upgrade-mysql-max
  • suse-upgrade-mysql-shared
  • suse-upgrade-mysql-shared-32bit
  • suse-upgrade-mysql-shared-64bit
  • suse-upgrade-mysql-shared-x86
  • suse-upgrade-mysql-test
  • suse-upgrade-mysql-tools

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;