Rapid7 Vulnerability & Exploit Database

SUSE Linux Security Vulnerability: CVE-2012-2763

Back to Search

SUSE Linux Security Vulnerability: CVE-2012-2763

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
07/12/2012
Created
07/25/2018
Added
02/17/2015
Modified
07/04/2017

Description

Buffer overflow in the readstr_upto function in plug-ins/script-fu/tinyscheme/scheme.c in GIMP 2.6.12 and earlier, and possibly 2.6.13, allows remote attackers to execute arbitrary code via a long string in a command to the script-fu server.

Solution(s)

  • suse-upgrade-gimp
  • suse-upgrade-gimp-branding-upstream
  • suse-upgrade-gimp-debuginfo
  • suse-upgrade-gimp-debugsource
  • suse-upgrade-gimp-devel
  • suse-upgrade-gimp-devel-debuginfo
  • suse-upgrade-gimp-help-browser
  • suse-upgrade-gimp-help-browser-debuginfo
  • suse-upgrade-gimp-lang
  • suse-upgrade-gimp-plugins-python
  • suse-upgrade-gimp-plugins-python-debuginfo
  • suse-upgrade-libgimp-2_0-0
  • suse-upgrade-libgimp-2_0-0-32bit
  • suse-upgrade-libgimp-2_0-0-debuginfo
  • suse-upgrade-libgimp-2_0-0-debuginfo-32bit
  • suse-upgrade-libgimp-2_0-0-debuginfo-x86
  • suse-upgrade-libgimp-2_0-0-x86
  • suse-upgrade-libgimpui-2_0-0
  • suse-upgrade-libgimpui-2_0-0-32bit
  • suse-upgrade-libgimpui-2_0-0-debuginfo
  • suse-upgrade-libgimpui-2_0-0-debuginfo-32bit
  • suse-upgrade-libgimpui-2_0-0-debuginfo-x86
  • suse-upgrade-libgimpui-2_0-0-x86

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;