Rapid7 Vulnerability & Exploit Database

Ubuntu: (Multiple Advisories) (CVE-2016-2384): Linux kernel (Raspberry Pi 2) vulnerabilities

Back to Search

Ubuntu: (Multiple Advisories) (CVE-2016-2384): Linux kernel (Raspberry Pi 2) vulnerabilities

Severity
5
CVSS
(AV:L/AC:L/Au:N/C:N/I:N/A:C)
Published
03/16/2016
Created
07/25/2018
Added
03/22/2016
Modified
09/12/2020

Description

Double free vulnerability in the snd_usbmidi_create function in sound/usb/midi.c in the Linux kernel before 4.5 allows physically proximate attackers to cause a denial of service (panic) or possibly have unspecified other impact via vectors involving an invalid USB descriptor.

Solution(s)

  • ubuntu-upgrade-linux-image-3-13-0-83-generic
  • ubuntu-upgrade-linux-image-3-13-0-83-generic-lpae
  • ubuntu-upgrade-linux-image-3-13-0-83-lowlatency
  • ubuntu-upgrade-linux-image-3-13-0-83-powerpc-e500
  • ubuntu-upgrade-linux-image-3-13-0-83-powerpc-e500mc
  • ubuntu-upgrade-linux-image-3-13-0-83-powerpc-smp
  • ubuntu-upgrade-linux-image-3-13-0-83-powerpc64-emb
  • ubuntu-upgrade-linux-image-3-13-0-83-powerpc64-smp
  • ubuntu-upgrade-linux-image-3-16-0-67-generic
  • ubuntu-upgrade-linux-image-3-16-0-67-generic-lpae
  • ubuntu-upgrade-linux-image-3-16-0-67-lowlatency
  • ubuntu-upgrade-linux-image-3-16-0-67-powerpc-e500mc
  • ubuntu-upgrade-linux-image-3-16-0-67-powerpc-smp
  • ubuntu-upgrade-linux-image-3-16-0-67-powerpc64-emb
  • ubuntu-upgrade-linux-image-3-16-0-67-powerpc64-smp
  • ubuntu-upgrade-linux-image-3-19-0-56-generic
  • ubuntu-upgrade-linux-image-3-19-0-56-generic-lpae
  • ubuntu-upgrade-linux-image-3-19-0-56-lowlatency
  • ubuntu-upgrade-linux-image-3-19-0-56-powerpc-e500mc
  • ubuntu-upgrade-linux-image-3-19-0-56-powerpc-smp
  • ubuntu-upgrade-linux-image-3-19-0-56-powerpc64-emb
  • ubuntu-upgrade-linux-image-3-19-0-56-powerpc64-smp
  • ubuntu-upgrade-linux-image-3-2-0-101-generic
  • ubuntu-upgrade-linux-image-3-2-0-101-generic-pae
  • ubuntu-upgrade-linux-image-3-2-0-101-highbank
  • ubuntu-upgrade-linux-image-3-2-0-101-omap
  • ubuntu-upgrade-linux-image-3-2-0-101-powerpc-smp
  • ubuntu-upgrade-linux-image-3-2-0-101-powerpc64-smp
  • ubuntu-upgrade-linux-image-3-2-0-101-virtual
  • ubuntu-upgrade-linux-image-3-2-0-1479-omap4
  • ubuntu-upgrade-linux-image-4-2-0-1027-raspi2
  • ubuntu-upgrade-linux-image-4-2-0-34-generic
  • ubuntu-upgrade-linux-image-4-2-0-34-generic-lpae
  • ubuntu-upgrade-linux-image-4-2-0-34-lowlatency
  • ubuntu-upgrade-linux-image-4-2-0-34-powerpc-e500mc
  • ubuntu-upgrade-linux-image-4-2-0-34-powerpc-smp
  • ubuntu-upgrade-linux-image-4-2-0-34-powerpc64-emb
  • ubuntu-upgrade-linux-image-4-2-0-34-powerpc64-smp

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;