Rapid7 Vulnerability & Exploit Database

VMware Horizon Client: CVE-2012-0897 VMware Workstation and Horizon Client memory manipulation issues (VMSA-2015-0004)

Back to Search

VMware Horizon Client: CVE-2012-0897 VMware Workstation and Horizon Client memory manipulation issues (VMSA-2015-0004)

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
01/20/2012
Created
07/16/2022
Added
05/25/2022
Modified
06/27/2022

Description

Stack-based buffer overflow in the JPEG2000 plugin in IrfanView PlugIns before 4.33 allows remote attackers to execute arbitrary code via a JPEG2000 (JP2) file with a crafted Quantization Default (QCD) marker segment.

Solution(s)

  • vmware-horizon-client-upgrade-3_2_1
  • vmware-horizon-client-upgrade-3_4_0
  • vmware-horizon-client-upgrade-5_4_2

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;