Rapid7 Vulnerability & Exploit Database

Kodi 17.0 Local File Inclusion Vulnerability

Back to Search

Kodi 17.0 Local File Inclusion Vulnerability

Disclosed
02/12/2017
Created
05/30/2018

Description

This module exploits a directory traversal flaw found in Kodi before 17.1.

Author(s)

  • Eric Flokstra
  • jvoisin

Development

References

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use auxiliary/scanner/http/kodi_traversal
msf auxiliary(kodi_traversal) > show actions
    ...actions...
msf auxiliary(kodi_traversal) > set ACTION < action-name >
msf auxiliary(kodi_traversal) > show options
    ...show and set options...
msf auxiliary(kodi_traversal) > run 

Time is precious, so I don’t want to do something manually that I can automate. Leveraging the Metasploit Framework when automating any task keeps us from having to re-create the wheel as we can use the existing libraries and focus our efforts where it matters.

– Jim O’Gorman | President, Offensive Security

;