Vulnerability & Exploit Database

Back to search

Linksys Devices pingstr Remote Command Injection

The Linksys WRT100 and WRT110 consumer routers are vulnerable to a command injection exploit in the ping field of the web interface.

Free Metasploit Download

Get your copy of the world's leading penetration testing tool

 Download Now

Module Name

exploit/linux/http/linksys_wrt110_cmd_exec

Authors

  • Craig Young
  • joev <joev [at] metasploit.com>
  • juan vazquez <juan.vazquez [at] metasploit.com>

References

Targets

  • Linux mipsel Payload

Platforms

  • linux

Architectures

  • mipsle

Reliability

Development

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/linux/http/linksys_wrt110_cmd_exec msf exploit(linksys_wrt110_cmd_exec) > show targets ...targets... msf exploit(linksys_wrt110_cmd_exec) > set TARGET <target-id> msf exploit(linksys_wrt110_cmd_exec) > show options ...show and set options... msf exploit(linksys_wrt110_cmd_exec) > exploit