Rapid7 Vulnerability & Exploit Database

Alma Linux: CVE-2021-20271: Moderate: rpm security update (ALSA-2021-2574)

Back to Search

Alma Linux: CVE-2021-20271: Moderate: rpm security update (ALSA-2021-2574)

Severity
5
CVSS
(AV:N/AC:H/Au:N/C:P/I:P/A:P)
Published
03/26/2021
Created
05/05/2022
Added
05/04/2022
Modified
05/04/2022

Description

A flaw was found in RPM's signature check functionality when reading a package file. This flaw allows an attacker who can convince a victim to install a seemingly verifiable package, whose signature header was modified, to cause RPM database corruption and execute code. The highest threat from this vulnerability is to data integrity, confidentiality, and system availability.

Solution(s)

  • alma-upgrade-python3-rpm
  • alma-upgrade-rpm
  • alma-upgrade-rpm-apidocs
  • alma-upgrade-rpm-build
  • alma-upgrade-rpm-build-libs
  • alma-upgrade-rpm-cron
  • alma-upgrade-rpm-devel
  • alma-upgrade-rpm-libs
  • alma-upgrade-rpm-plugin-fapolicyd
  • alma-upgrade-rpm-plugin-ima
  • alma-upgrade-rpm-plugin-prioreset
  • alma-upgrade-rpm-plugin-selinux
  • alma-upgrade-rpm-plugin-syslog
  • alma-upgrade-rpm-plugin-systemd-inhibit
  • alma-upgrade-rpm-sign

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;