Rapid7 Vulnerability & Exploit Database

Alma Linux: CVE-2023-23916: Moderate: curl security update (ALSA-2023-1701)

Free InsightVM Trial No Credit Card Necessary
Watch Demo See how it all works
Back to Search

Alma Linux: CVE-2023-23916: Moderate: curl security update (ALSA-2023-1701)

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
02/23/2023
Created
03/15/2023
Added
03/14/2023
Modified
02/19/2024

Description

An allocation of resources without limits or throttling vulnerability exists in curl <v7.88.0 based on the "chained" HTTP compression algorithms, meaning that a server response can be compressed multiple times and potentially with differentalgorithms. The number of acceptable "links" in this "decompression chain" wascapped, but the cap was implemented on a per-header basis allowing a maliciousserver to insert a virtually unlimited number of compression steps simply byusing many headers. The use of such a decompression chain could result in a "malloc bomb", making curl end up spending enormous amounts of allocated heap memory, or trying to and returning out of memory errors.

Solution(s)

  • alma-upgrade-curl
  • alma-upgrade-curl-minimal
  • alma-upgrade-libcurl
  • alma-upgrade-libcurl-devel
  • alma-upgrade-libcurl-minimal

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;