Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2014-9705: php issues fixed in 5.6.6

Back to Search

Alpine Linux: CVE-2014-9705: php issues fixed in 5.6.6

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
03/30/2015
Created
07/25/2018
Added
08/30/2017
Modified
01/08/2018

Description

Heap-based buffer overflow in the enchant_broker_request_dict function in ext/enchant/enchant.c in PHP before 5.4.38, 5.5.x before 5.5.22, and 5.6.x before 5.6.6 allows remote attackers to execute arbitrary code via vectors that trigger creation of multiple dictionaries.

Solution(s)

  • alpine-linux-upgrade-php

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;