An issue was discovered in certain Apple products. Safari before 10.1 is affected. The issue involves the "WebKit" component. It allows attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted app.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Alpine Linux | — | Upgrade webkit2gtk | Aug 30, 2017 | Apr 1, 2017 |
| Apple Osx Webkit | — | Apply OS X security update 2017-001Upgrade macOS to the latest version | Mar 28, 2017 | Mar 28, 2017 |
| Apple Safari | — | Upgrade to Apple Safari version 10.1Uninstall Apple Safari on Windows | Apr 3, 2017 | Apr 1, 2017 |
| Arch Linux | — | Upgrade to the latest version of Arch Linux | Jul 11, 2025 | Apr 2, 2017 |
| Debian | — | Upgrade webkit2gtk | Jul 30, 2024 | Apr 2, 2017 |
| Gentoo Linux | — | Upgrade net-libs/webkit-gtk. | Oct 30, 2017 | Apr 1, 2017 |
| Oracle Solaris | — | Upgrade entire/ to version 11.4-11.4.0.0.1.15.0 on Solaris 11.4 | Oct 19, 2018 | Apr 1, 2017 |
| Ubuntu | — | Upgrade libwebkit2gtk-4.0-37Upgrade libjavascriptcoregtk-4.0-18 | Apr 11, 2017 | Apr 1, 2017 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub