Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2018-16837: ansible Multiple vulnerabilities

Back to Search

Alpine Linux: CVE-2018-16837: ansible Multiple vulnerabilities

Severity
2
CVSS
(AV:L/AC:L/Au:N/C:P/I:N/A:N)
Published
10/23/2018
Created
12/18/2019
Added
12/12/2019
Modified
12/27/2019

Description

Ansible "User" module leaks any data which is passed on as a parameter to ssh-keygen. This could lean in undesirable situations such as passphrases credentials passed as a parameter for the ssh-keygen executable. Showing those credentials in clear text form for every user which have access just to the process list.

Solution(s)

  • alpine-linux-upgrade-ansible

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;