Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2019-18934: unbound Vulnerability in IPSEC module

Back to Search

Alpine Linux: CVE-2019-18934: unbound Vulnerability in IPSEC module

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
11/19/2019
Created
12/18/2019
Added
11/27/2019
Modified
12/18/2019

Description

Unbound 1.6.4 through 1.9.4 contain a vulnerability in the ipsec module that can cause shell code execution after receiving a specially crafted answer. This issue can only be triggered if unbound was compiled with `--enable-ipsecmod` support, and ipsecmod is enabled and used in the configuration.

Solution(s)

  • alpine-linux-upgrade-unbound

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;