Node.js < 14.11.0 is vulnerable to HTTP denial of service (DoS) attacks based on delayed requests submission which can make the server unable to accept new connections.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Alpine Linux | — | Upgrade nodejs-current | Aug 22, 2024 | Sep 18, 2020 |
| Amazon Linux Ami 2 | — | Upgrade libuv-develUpgrade libuv-debuginfoUpgrade libuv-staticUpgrade libuv | Jan 8, 2021 | Sep 18, 2020 |
| Freebsd | — | Upgrade node10Upgrade node12Upgrade node | Sep 17, 2020 | Sep 16, 2020 |
| Gentoo Linux | — | Upgrade net-libs/nodejs. | Jan 12, 2021 | Sep 18, 2020 |
| Oracle Solaris | — | Upgrade runtime/nodejs to version 12.19.1-11.4.30.0.1.88.0 on Solaris 11.4Upgrade runtime/nodejs/nodejs-10 to version 10.22.1-11.4.30.0.1.88.0 on Solaris 11.4Upgrade runtime/nodejs/nodejs-12 to version 12.19.1-11.4.30.0.1.88.0 on Solaris 11.4 | Feb 17, 2021 | Sep 18, 2020 |
| Suse | — | Upgrade nodejs14-docsUpgrade npm14Upgrade nodejs14Upgrade nodejs14-devel | Feb 4, 2022 | Sep 8, 2020 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub