Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI 2: CVE-2015-6525: Security patch for libevent (ALAS-2019-1359)

Back to Search

Amazon Linux AMI 2: CVE-2015-6525: Security patch for libevent (ALAS-2019-1359)

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
08/24/2015
Created
05/08/2020
Added
04/27/2020
Modified
09/30/2022

Description

Multiple integer overflows in the evbuffer API in Libevent 2.0.x before 2.0.22 and 2.1.x before 2.1.5-beta allow context-dependent attackers to cause a denial of service or possibly have other unspecified impact via "insanely large inputs" to the (1) evbuffer_add, (2) evbuffer_prepend, (3) evbuffer_expand, (4) exbuffer_reserve_space, or (5) evbuffer_read function, which triggers a heap-based buffer overflow or an infinite loop. NOTE: this identifier was SPLIT from CVE-2014-6272 per ADT3 due to different affected versions.

Solution(s)

  • amazon-linux-ami-2-upgrade-libevent
  • amazon-linux-ami-2-upgrade-libevent-debuginfo
  • amazon-linux-ami-2-upgrade-libevent-devel
  • amazon-linux-ami-2-upgrade-libevent-doc

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;