Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI 2: CVE-2018-1122: Security patch for procps-ng (ALAS-2019-1333)

Back to Search

Amazon Linux AMI 2: CVE-2018-1122: Security patch for procps-ng (ALAS-2019-1333)

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
05/23/2018
Created
05/08/2020
Added
04/27/2020
Modified
09/30/2022

Description

procps-ng before version 3.3.15 is vulnerable to a local privilege escalation in top. If a user runs top with HOME unset in an attacker-controlled directory, the attacker could achieve privilege escalation by exploiting one of several vulnerabilities in the config_file() function.

Solution(s)

  • amazon-linux-ami-2-upgrade-procps-ng
  • amazon-linux-ami-2-upgrade-procps-ng-debuginfo
  • amazon-linux-ami-2-upgrade-procps-ng-devel
  • amazon-linux-ami-2-upgrade-procps-ng-i18n

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;