Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI 2: CVE-2018-15518: Security patch for qt, qt5-qtbase (Multiple Advisories)

Back to Search

Amazon Linux AMI 2: CVE-2018-15518: Security patch for qt, qt5-qtbase (Multiple Advisories)

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
12/26/2018
Created
05/08/2020
Added
04/27/2020
Modified
07/21/2020

Description

QXmlStream in Qt 5.x before 5.11.3 has a double-free or corruption during parsing of a specially crafted illegal XML document.

Solution(s)

  • amazon-linux-ami-2-upgrade-qt
  • amazon-linux-ami-2-upgrade-qt-assistant
  • amazon-linux-ami-2-upgrade-qt-config
  • amazon-linux-ami-2-upgrade-qt-debuginfo
  • amazon-linux-ami-2-upgrade-qt-demos
  • amazon-linux-ami-2-upgrade-qt-devel
  • amazon-linux-ami-2-upgrade-qt-devel-private
  • amazon-linux-ami-2-upgrade-qt-doc
  • amazon-linux-ami-2-upgrade-qt-examples
  • amazon-linux-ami-2-upgrade-qt-mysql
  • amazon-linux-ami-2-upgrade-qt-odbc
  • amazon-linux-ami-2-upgrade-qt-postgresql
  • amazon-linux-ami-2-upgrade-qt-qdbusviewer
  • amazon-linux-ami-2-upgrade-qt-qvfb
  • amazon-linux-ami-2-upgrade-qt-x11
  • amazon-linux-ami-2-upgrade-qt5-qtbase
  • amazon-linux-ami-2-upgrade-qt5-qtbase-common
  • amazon-linux-ami-2-upgrade-qt5-qtbase-debuginfo
  • amazon-linux-ami-2-upgrade-qt5-qtbase-devel
  • amazon-linux-ami-2-upgrade-qt5-qtbase-doc
  • amazon-linux-ami-2-upgrade-qt5-qtbase-examples
  • amazon-linux-ami-2-upgrade-qt5-qtbase-gui
  • amazon-linux-ami-2-upgrade-qt5-qtbase-mysql
  • amazon-linux-ami-2-upgrade-qt5-qtbase-odbc
  • amazon-linux-ami-2-upgrade-qt5-qtbase-postgresql
  • amazon-linux-ami-2-upgrade-qt5-qtbase-static
  • amazon-linux-ami-2-upgrade-qt5-rpm-macros

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;