Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI 2: CVE-2019-11727: Security patch for nss, nss-softokn, nss-util, nspr (ALAS-2020-1559)

Back to Search

Amazon Linux AMI 2: CVE-2019-11727: Security patch for nss, nss-softokn, nss-util, nspr (ALAS-2020-1559)

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:P/A:N)
Published
07/23/2019
Created
11/13/2020
Added
11/12/2020
Modified
11/12/2020

Description

A vulnerability exists where it possible to force Network Security Services (NSS) to sign CertificateVerify with PKCS#1 v1.5 signatures when those are the only ones advertised by server in CertificateRequest in TLS 1.3. PKCS#1 v1.5 signatures should not be used for TLS 1.3 messages. This vulnerability affects Firefox < 68.

Solution(s)

  • amazon-linux-ami-2-upgrade-nspr
  • amazon-linux-ami-2-upgrade-nspr-debuginfo
  • amazon-linux-ami-2-upgrade-nspr-devel
  • amazon-linux-ami-2-upgrade-nss
  • amazon-linux-ami-2-upgrade-nss-debuginfo
  • amazon-linux-ami-2-upgrade-nss-devel
  • amazon-linux-ami-2-upgrade-nss-pkcs11-devel
  • amazon-linux-ami-2-upgrade-nss-softokn
  • amazon-linux-ami-2-upgrade-nss-softokn-debuginfo
  • amazon-linux-ami-2-upgrade-nss-softokn-devel
  • amazon-linux-ami-2-upgrade-nss-softokn-freebl
  • amazon-linux-ami-2-upgrade-nss-softokn-freebl-devel
  • amazon-linux-ami-2-upgrade-nss-sysinit
  • amazon-linux-ami-2-upgrade-nss-tools
  • amazon-linux-ami-2-upgrade-nss-util
  • amazon-linux-ami-2-upgrade-nss-util-debuginfo
  • amazon-linux-ami-2-upgrade-nss-util-devel

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;