Rapid7 Vulnerability & Exploit Database

Apache HTTPD: mod_rewrite off-by-one error (CVE-2006-3747)

Back to Search

Apache HTTPD: mod_rewrite off-by-one error (CVE-2006-3747)

Severity
8
CVSS
(AV:N/AC:H/Au:N/C:C/I:C/A:C)
Published
07/28/2006
Created
07/25/2018
Added
04/12/2012
Modified
05/27/2016

Description

The affected asset is vulnerable to this vulnerability ONLY if it is running one of the following modules: mod_rewrite. Review your web server configuration for validation. An off-by-one flaw exists in the Rewrite module, mod_rewrite. Depending on the manner in which Apache httpd was compiled, this software defect may result in a vulnerability which, in combination with certain types of Rewrite rules in the web server configuration files, could be triggered remotely. For vulnerable builds, the nature of the vulnerability can be denial of service (crashing of web server processes) or potentially allow arbitrary code execution.

Solution(s)

  • apache-httpd-upgrade-1_3_37
  • apache-httpd-upgrade-2_0_59
  • apache-httpd-upgrade-2_2_3

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;