Rapid7 Vulnerability & Exploit Database

Apache HTTPD: Expect header Cross-Site Scripting (CVE-2006-3918)

Back to Search

Apache HTTPD: Expect header Cross-Site Scripting (CVE-2006-3918)

Severity
4
CVSS
(AV:N/AC:M/Au:N/C:N/I:P/A:N)
Published
07/27/2006
Created
07/25/2018
Added
04/12/2012
Modified
02/13/2015

Description

The affected asset is vulnerable to this vulnerability ONLY if an attacker can influence the Expect header, for example using Flash. Review your web server configuration for validation. A flaw in the handling of invalid Expect headers. If an attacker can influence the Expect header that a victim sends to a target site they could perform a cross-site scripting attack. It is known that some versions of Flash can set an arbitrary Expect header which can trigger this flaw. Not marked as a security issue for 2.0 or 2.2 as the cross-site scripting is only returned to the victim after the server times out a connection.

Solution(s)

  • apache-httpd-upgrade-1_3_35

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;