Multiple cross-site scripting (XSS) vulnerabilities in the (1) Manager and (2) Host Manager web applications in Apache Tomcat 4.0.0 through 4.0.6, 4.1.0 through 4.1.36, 5.0.0 through 5.0.30, 5.5.0 through 5.5.24, and 6.0.0 through 6.0.13 allow remote authenticated users to inject arbitrary web script or HTML via a parameter name to manager/html/upload, and other unspecified vectors.
| Product | Vendor Advisory | Solution File | Added | Published |
|---|---|---|---|---|
| Apache Tomcat | — | Upgrade Apache Tomcat to 6.0.14Upgrade Apache Tomcat to the latest available versionUpgrade Apache Tomcat to 5.0.0Upgrade Apache Tomcat to 4.1.37Upgrade Apache Tomcat to 5.5.25 | May 17, 2012 | Jun 14, 2007 |
| Apple Osx Tomcat | — | Apply OS X security update 2008-004 | Dec 16, 2011 | Jun 14, 2007 |
| Oracle_linux | — | Upgrade tomcat5Upgrade tomcat5-admin-webappsUpgrade tomcat5-jasper-javadocUpgrade tomcat5-common-libUpgrade tomcat5-server-libUpgrade tomcat5-servlet-2.4-apiUpgrade tomcat5-jasperUpgrade tomcat5-jsp-2.0-apiUpgrade tomcat5-servlet-2.4-api-javadocUpgrade tomcat5-webappsUpgrade tomcat5-jsp-2.0-api-javadoc | Oct 16, 2024 | Jun 14, 2007 |
| Suse | — | Upgrade tomcat5Upgrade jakarta-tomcat-examplesUpgrade tomcat55-jasperUpgrade tomcat55-common-libUpgrade tomcat5-webappsUpgrade suse-releaseUpgrade tomcat5-admin-webappsUpgrade apache2-jakarta-tomcat-connectorsUpgrade tomcat55Upgrade tomcat55-server-libUpgrade tomcat55-servlet-2_4-api-javadocUpgrade tomcat55-admin-webappsUpgrade tomcat55-jasper-javadocUpgrade tomcat55-webappsUpgrade tomcat55-jsp-2_0-apiUpgrade tomcat55-servlet-2_4-apiUpgrade apache-jakarta-tomcat-connectorsUpgrade jakarta-tomcat-docUpgrade tomcat55-jsp-2_0-api-javadocUpgrade jakarta-tomcat | Feb 17, 2015 | Jun 14, 2007 |
With curated Threat Intelligence, you can see which vulnerabilities truly put you at risk, prioritize what matters most, and act before attackers do.
Explore Intelligence Hub